Slick Forums

Discuss the Slick 2D Library
It is currently Sun Oct 20, 2019 9:54 pm

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Mar 14, 2015 8:27 am 
Offline

Joined: Fri Jan 30, 2015 2:42 am
Posts: 6
I am making a project where you launch it in swing and then when your die(in the game) you return to the swing frame. I have all this working but when I re enter the game it doesnt load the graphics it puts white boxes instead. I am using AppGameContianer.exit() to go back to the swing application and just making a new AppGameContainer(agc) when entering the game. The swing application just runs a method which creates a new instance of the agc and then sets the display settings then goes agc.start(). The code for the project is very long so it is probably not good to put it in here. I really need help on this fast as it is due on Tuesday.


Top
 Profile  
 
PostPosted: Sat Mar 14, 2015 8:29 am 
Offline

Joined: Fri Jan 30, 2015 2:42 am
Posts: 6
I also want to add that when the game is re entered with the graphics problem all the game play and stuff still works.


Top
 Profile  
 
PostPosted: Sun Mar 15, 2015 9:52 am 
Offline

Joined: Fri Jan 30, 2015 2:42 am
Posts: 6
also when loading the game at first it outputs:
Code:
Sun Mar 15 17:48:27 AWST 2015 INFO:Slick Build #237
Sun Mar 15 17:48:27 AWST 2015 INFO:LWJGL Version: 2.9.3
Sun Mar 15 17:48:27 AWST 2015 INFO:OriginalDisplayMode: 1920 x 1080 x 32 @59Hz
Sun Mar 15 17:48:27 AWST 2015 INFO:TargetDisplayMode: 700 x 500 x 0 @0Hz
Sun Mar 15 17:48:27 AWST 2015 INFO:Starting display 700x500
Sun Mar 15 17:48:27 AWST 2015 INFO:Use Java PNG Loader = true
WARNING: Found unknown Windows version: Windows 8.1
Attempting to use default windows plug-in.
Loading: net.java.games.input.DirectAndRawInputEnvironmentPlugin
Sun Mar 15 17:48:27 AWST 2015 INFO:Found 4 controllers
Sun Mar 15 17:48:27 AWST 2015 INFO:0 : ndPoint1 Inte
Sun Mar 15 17:48:27 AWST 2015 INFO:1 : ndPoint1 Inte
Sun Mar 15 17:48:27 AWST 2015 INFO:2 : Razer Taipan
Sun Mar 15 17:48:27 AWST 2015 INFO:3 : Razer Taipan


then when I restart the game while still running the swing app it out puts:
Code:
Sun Mar 15 17:48:31 AWST 2015 INFO:Slick Build #237
Sun Mar 15 17:48:31 AWST 2015 INFO:LWJGL Version: 2.9.3
Sun Mar 15 17:48:31 AWST 2015 INFO:OriginalDisplayMode: 1920 x 1080 x 32 @59Hz
Sun Mar 15 17:48:31 AWST 2015 INFO:TargetDisplayMode: 700 x 500 x 0 @0Hz
Sun Mar 15 17:48:31 AWST 2015 INFO:Starting display 700x500


Then you die and go back to the swing app. I thought it was because you died to fast but then I slept it and the same thing happened.


Top
 Profile  
 
PostPosted: Mon Jan 09, 2017 10:39 am 
Offline

Joined: Mon Jan 09, 2017 10:35 am
Posts: 2
I know this thread is very old, but I have the exact same problem. Do you know/remember how to solve it? I have had this problem for over a month now! :|


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: MSN [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group