Slick Forums

Discuss the Slick 2D Library
It is currently Mon Jul 16, 2018 10:43 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Jan 09, 2017 1:07 pm 
Offline

Joined: Mon Jan 09, 2017 10:35 am
Posts: 2
I am having a visual problem with the project I'm working on. We are making a Bomberman clone, and use fxml for our main application and lobby system.
When a lobby is created and enough players join and start a game, an AppGameContainer is created for each player.
This works like a charm the first time,

Attachment:
File comment: The first time (Correct)
Bomberman.png
Bomberman.png [ 147.06 KiB | Viewed 635 times ]


but when the same client joins his second game (New AppGameContainer), the game starts but there is this visual problem:

Attachment:
File comment: The Second or higher time (Bugged)
Bomberman Bugged.png
Bomberman Bugged.png [ 7.15 KiB | Viewed 635 times ]


The input is still handled correctly, and the render function is still running. But the screen is mostly white, the chat is black, and the text is blocky.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group